Server Maintenance 21 March 2026
Scheduled for 21 March 2026 at 7:00 AM – 10:00 AM
Affects
Hosted PBX - 3CX
Under maintenance from 7:00 AM to 10:00 AM
Completed
21 March 2026 at 10:00 AMCompleted
21 March 2026 at 10:00 AMMaintenance has completed successfully
In progress
21 March 2026 at 7:00 AMIn progress
21 March 2026 at 7:00 AMMaintenance is now in progress
Planned
21 March 2026 at 7:00 AMPlanned
21 March 2026 at 7:00 AMWe are planning for a scheduled maintenance during this time. We don't expect any services to be affected.